High Quality Chainsaw Bars Husqvarna Toys

MS880 Running rich (modded)

silverpsd06

OPE Member
Local time
9:40 AM
User ID
27432
Joined
Sep 8, 2023
Messages
5
Reaction score
0
Location
Ottawa, KS
Country flag
I have woods ported a MS880 and swapped coils to the unlimited 088 coil.. After assembly the saw will not lean out on the high needle, high needle will respond with more fuel but nothing less even seated snug. Low responds normally. I have tried adjusting timing from slightly advanced to extremely retarded and everything in between, no considerable difference. Am I overlooking something? Saw was a solid runner before modding..
 

Powerstroke Cowboy

Pinnacle OPE Member
GoldMember
Local time
8:40 AM
User ID
26178
Joined
Feb 23, 2023
Messages
1,268
Reaction score
3,711
Location
Montana
Country flag
Just to clarify, it ran good ported? But not with the new unlimited coil? Was the coil the only change that was made before the said problems?

Is your the new style ms880 or old style ms880? Clip on muffle or bolted on muffler?
 

Maintenance Chief

Disrupting the peace with an old chainsaw
Local time
10:40 AM
User ID
11378
Joined
Jan 4, 2020
Messages
3,818
Reaction score
12,064
Location
South Carolina
Country flag
Did you pressure test the pop off of the carburetor? Could just be trash under the needle.
 

silverpsd06

OPE Member
Local time
9:40 AM
User ID
27432
Joined
Sep 8, 2023
Messages
5
Reaction score
0
Location
Ottawa, KS
Country flag
Pressure tested the carb to 15PSI, saw was a runner before any mods, has a cast aluminum muffler (clip on and has been modded albeit ugly). Taken carb apart, removed needles and brake cleaned through them no change. Is there a bypass circuit in these carbs? It's a Walbro.
 

Ketchup

Epoxy member
Local time
8:40 AM
User ID
5594
Joined
Mar 12, 2018
Messages
1,884
Reaction score
5,620
Location
Colorado
Country flag
Both gates are operating through their full range? Filters are clean? Lever seated properly under diaphragm?
 

silverpsd06

OPE Member
Local time
9:40 AM
User ID
27432
Joined
Sep 8, 2023
Messages
5
Reaction score
0
Location
Ottawa, KS
Country flag
I think I have found the solution to my issues, going to experiment with plugging one of the jets inside the carburetor. Will report back carburetor is a WG-12A.

Filters aren't new but definitely not dirty enough to cause this issue, both needles will work through full range of leanest setting to richest.
 

Ketchup

Epoxy member
Local time
8:40 AM
User ID
5594
Joined
Mar 12, 2018
Messages
1,884
Reaction score
5,620
Location
Colorado
Country flag
I meant the throttle and choke gates/butterflies. The choke vein on my 394 got stuck partially closed and gave me fits. I’ve also had lots of problems making my own throttle linkages that didn’t open the throttle all the way. The last 10 degrees make a big difference.
 

silverpsd06

OPE Member
Local time
9:40 AM
User ID
27432
Joined
Sep 8, 2023
Messages
5
Reaction score
0
Location
Ottawa, KS
Country flag
I have not investigated that but I will take a look at them. I'd assume they're fine since it's all OEM
 
Top